The cluster does not support Query services

#1

Hi everyone;
This exception is almost curious, because I have two servers: ubuntu and windows server.

App and Couchbase server are in the same server:

Couchbase : You are running version 4.0.0-2213 DEV Edition (build-2213).
Client: NetClient v 2.1.3.0.

At ubuntu when I execute some tests occur this:

https://issues.couchbase.com/browse/NCBC-913

for another hand, Windows Server I put the same configuration like another servers, Query, Index and Data available for the same server.

At the windows server, I ran a query at cbq, but when I tried running query using SDK throw an exception:

The cluster does not support Query services

Regards

#2

@Antx2207 -

This indicates that the query service wasn’t enabled on Couchbase Server. You might want to double check that you have done this. If that’s not the problem, it could be a bug; enable client side logging (with INFO level minimum) and post the logs to an NCBC ticket…we just need to see the client initialization portion, so it doesn’t have to be a big file.

-Jeff

#3

@jmorris,

Do you request me the configuration?

var _config = new Couchbase.Configuration.Client.ClientConfiguration
                {
                    Servers = new List<Uri>
                  {
                       new Uri("http://localhost:8091/pools")
                  },
                    UseSsl = false,
                    DefaultOperationLifespan = int.MaxValue,
                    BucketConfigs = new Dictionary<string, Couchbase.Configuration.Client.BucketConfiguration>
                                  {
                                    {"default", new Couchbase.Configuration.Client.BucketConfiguration
                                    {
                                      BucketName = "default",
                                      UseSsl = false,
                                      Password = "",
                                      DefaultOperationLifespan = 2000,
                                     
                                      PoolConfiguration = new Couchbase.Configuration.Client.PoolConfiguration
                                      {
                                        MaxSize = int.MaxValue,
                                        MinSize = int.MaxValue - 1,
                                        SendTimeout = int.MaxValue,
                                        ConnectTimeout=int.MaxValue
                                      }
                                    }}}
                };
                instance = new Cluster(_config); 

I attach more detail about my config and another things.
https://mega.nz/#!AxZEnABK!blXhNLLXjoJdsO1ZcjlgcD3_OX0FQ5AeGApBNOBPj7A

Regards.

#4

@Antx2207 -

I need the cluster map - here are directions for enabling logging: http://docs.couchbase.com/developer/dotnet-2.1/setting-up-logging.html

-Jeff

#5

@jmorris,

Attach the log
https://mega.nz/#!B8QwhDAI!KVll4srefZ1dgp-4V0jzyzP19cBqCbB1Yf4wg_tEUlY

Regards

#6

@Antx2207-

The problem is not related to the error message you are receiving (see http://issues.couchbase.com/browse/NCBC-940 for more context). The error is that your PoolConfiguration settings are too high and creating an arithmetic overflow exception while the client is trying to bootstrap.

You just need to reduce the MaxSize and MinSize to something like 10 and 5; the defaults are 2 and 1 and those will probably suffice, but if you want to increase it give it something reasonable.

I created a ticket to add upper and lower bounds checks for MaxSize and MinSize: http://issues.couchbase.com/browse/NCBC-958

The defaults for SendTimeout and ConnectTimeout should also be sufficient, so remove the assignment of Int.MaxValue from those as well.

-Jeff

#7

Resolved, thanks a lot.

Regards.

1 Like