Travel App | Login not working on NGINX reverse proxy

40-beta

#1

I’ve setup couchbase server on an ubuntu remote server, and I’m trying to get the ‘Travel App’ running correctly. I’m able to access the login screen however when I generate the post request to:

POST http://104.236.207.40:3000/api/user/login 500 (Internal Server Error)

I’m getting this error please advice on this. Keep in mind I’m working on a reverse proxy with nginx so I’m not entirely sure how and why this is affecting the http post request to login please advice on this:

server {
listen 80;
listen [::]:80;
listen 443 ssl;
server_name 104.236.207.40;

# pass the request to the node.js server with the correct headers and much more can be added, see nginx config options
location / {

	proxy_pass http://localhost:3000;
	proxy_redirect off;

	proxy_set_header Host $host;
	proxy_set_header X-Real-IP $remote_addr;
	proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
	proxy_max_temp_file_size 0;

	client_max_body_size 10m;
	client_body_buffer_size 128k;

	proxy_connect_timeout 90;
	proxy_send_timeout 90;
	proxy_read_timeout 90;

	proxy_buffer_size 10k;
	proxy_buffers 8 16k;
	proxy_busy_buffers_size 64k;
	proxy_temp_file_write_size 64k;
}
location ~ ^/(images/|img/|javascript/|js/|css/|stylesheets/|flash/|media/|static/|robots.txt|humans.txt|favicon.ico) { 
	expires max; 
} 
 }

#2

Hi,

Are you able to run it in an environment locally to test, before trying to run with a proxy in the middle? IE, on the Ubuntu box locally, before trying it remote?

Thanks

Todd


#3

No I’m reinstalling couchbase server now…


#4

I did not configure the couchbase server at all, after doing so it ran perfectly. Thanks