Two instances of couchbase lite eternally out of sync

.net

#1

I’ve got two apps that are working with couchbase lite. I push a document to the backend with one machine, and start a pull replication on the other machine, but it never actually pulls the document. If I try to push a document with the same ID on the other machine, it will just make a local copy and never actually interact with the server. I can continually update it on whatever machine initially pushed it up to the server, and that will update the server copy.

The channels they are using are the same, and both machines create the document with push/pull replication. As far as I know, nothing on the server side has changed, but couchbase lite just won’t pull the document if the other machine created it.

Does anybody have any tips for this? I can provide a little bit more detail if it would help.


#2

What version of couchbase , sync gateway, CBL you have ? Its always best to tell the versions in the question.

Now if you have 4.X as CBS and 1.X sync gateway and CBL then do note inserting data directly to the backend will not help.

Do you have a load balancer in front of sync gateway?

if you are using 5.X as couchbase server and 1.5/2.0 as sync gateway then are you using enable_shared_bucket_access and import_docs property correctly.


#3

Are you sure the user trying to pull the document has permissions to do so? Are you using authenticated users or the GUEST user? If you are using an authenticated user, what channels do they have access to? What channel(s) is the document in?