Unable to change the port of couchbase server


#1

Hi ,
I am unable to change the port of the couchbase server and its default 8091.So when I use CLI
like :- ./couchbase-cli cluster-init -c localhost:8091 -u Administrator -p password --cluster-init-port=9090

but it is giving the error :- ERROR: option cluster-ramsize is not specified.

Please help.


#2

you do need to specify the --cluster-ramsize option on cluster init. However there is a bug that return the error even when you specify the cluster-ramsize. I logged an issue for tracking this:
https://issues.couchbase.com/browse/MB-18092

./couchbase-cli cluster-init -c localhost:8091 -u couchbase123 -p couchbase123 --cluster-init-port=9090 --cluster-ramsize=1000

this should return the following. and pls ignore the error because the operation succeeded.

ERROR: option cluster-ramsize is not specified
SUCCESS: init/edit localhost


#3

Hi cihangirb,

I had run this command below and found it is runnig sucessfully.

couchbase-cli cluster-edit -c localhost:8091 -u user_name -p password --cluster- username=user_name --cluster-password=password --cluster-port=9000

And your solution that you have posted is also working .

Thanks cihangirb for you time.


#4

I should have asked the build number you are using first. which version of couchbase are you on?


#5

I am using Couchbase Server 4.1


#6

got it. I’ll try it with that version but I was trying this on the latest builds on 4.5 that we are about to preview in the next few weeks.
thanks
-cihan