Unable to create secondary index on multiple nodes

query
n1ql

#1

I have 3 node cluster, i am trying to create secondary index on multiple nodes while doing getting error.

cbq> CREATE INDEX index_name ON bucket(col_name) USING GSI WITH {“nodes”:[“xx.xx.xx.xx:8091”, “xx.xx.xx.xx:8091”] };
{
“requestID”: “bd9c3df5-09ce-4afa-a6b1-47cbdea9a6c7”,
“signature”: null,
“results”: [
],
“errors”: [
{
“code”: 5000,
“msg”: “GSI CreateIndex() - cause: Encounter errors during create index. Error=Index Replica not supported in non-Enterprise Edition\n.”
}
],
“status”: “errors”,
“metrics”: {
“elapsedTime”: “9.11707ms”,
“executionTime”: “9.082142ms”,
“resultCount”: 0,
“resultSize”: 0,
“errorCount”: 1
}
}


#2

In the web console, go to “settings” in each server and check if in the “Index Storage Mode” the “Standard Global Secondary” option is selected

Memory-Optimized indexes are only supported in the enterprise version, https://developer.couchbase.com/documentation/server/current/introduction/editions.html


#3

System managed replicas are supported in EE version only. In the WITH clause, “nodes” can have only 1 node in CE. You can create manual replica(equivalent index) in CE.


#4

@rohit.vangari: See the post by @venkat.
https://blog.couchbase.com/couchbase-index-replicas/


#5

Hi deniswsrosa,

that is already set "Standard Global Secondary” mode.


#6

This tread is miss-leading. The correct answer is that index partitioning/replicas are not available in Community Edition period.

This is mentioned no where in the documentation, blog, etc.