Unable to upgrade Couchbase


I have on my laptop Couchbase 5.0.1 Community.

I ran the installer for Couchbase 6.0.0 Community and I keep getting “Couchbase setup ended prematurely because of an error”.

What should I do?

Now my 5.0.1 is not fuctioning.
Repair didn’t work, and Remove is telling me to install Universal C…

Whats going on?

Hi Alon,
Thanks for using our product.
Before answer your question, I have some questions to ask you.
What is your operating system? If it is windows, what is build windows version?
What services you set up for 5.0.0 cluster?

I’m using Windows 10 Enterprise 1803 (OS Build: 17134.829)

I’m not using a cluster. This is my development machine.

The only way I was able to get my Couchbase 5 back is to uninstall it from the add/remove programs and reinstall it.
But then when I tried upgrading to 6 immediately after I installed and configured 5 (4 ephermal buckets, 1 couchbase bucket, 1 user, 1 GSI index on the couchbase bucket), I got the same problems all over again. It keeps rolling back the installation for some reason.

This time I uninstalled again and tried installing 6 directly and it worked.