Unauthenticated projector and indexer REST endpoints

There is a mention of security vulnerability on couchbase website (https://www.couchbase.com/resources/security#SecurityAlerts) as below.
Synopsis:
Unauthenticated projector and indexer REST endpoints

Update all projector and indexer REST endpoints to require authentication

Affected versions:
4.0.0
5.0.0
5.5.0
5.5.1

Fixed versons:
6.0.0
5.5.2
5.1.2

Now, i couldn’t get any more details on this issue.Synopsis does not seem to be informative. Can anyone point me somewhere this issue is properly documented and its available fix? As of now, all i can understand is to upgrade the version and deploy any of the fixed version.