Update Couchbase server to 5.5.1 version on AWS


#1

Hello,
I am trying to upgrade Couchbase server to 5.5.1 version on AWS. Currently it is of version 5.5.1. On the AWS ami this is the current rpm: couchbase-server-5.1.0-5552.x86_64. I tried to upgrade with this rpm(couchbase-server-5.5.1-5552.x86_64).

Steps followed:
curl -O http://packages.couchbase.com/releases/couchbase-release/couchbase-server-5.5.1-5552.x86_64
rpm -Uvh couchbase-server-5.5.1-5552.x86_64

It failed with the following error:
[ec2-user@ip-10-150-159-93 ~]$ rpm -Uvh couchbase-server-5.5.1-5552.x86_64
error: couchbase-server-5.5.1-5552.x86_64: not an rpm package (or package manifest):
Can you please provide the right rpm and the steps to upgrade the Couchbase server to 5.5.1 version.
Thanks,
Bharathi.


#2

Your URL is incorrect. All you’re downloading with your curl -O is an error message.

$ less couchbase-server-5.5.1-5552.x86_64 
<?xml version="1.0" encoding="UTF-8"?>
<Error><Code>NoSuchKey</Code><Message>The specified key does not exist.</Message><Key>releases/couchbase-release/couchbase-server-5.5.1-5552.x86_64</Key><RequestId>4775B67679DC64AC</RequestId><HostId>TCHKIijdol6ERfvYmyCC/teOfHuffdFxs9woz+CkyeSAjPzLZkVVKcVe8+bYz6XuSs81J7nl69E=</HostId></Error>

Double check your URL.