Update libcouchbase on Ubuntu 14.04.3 LTS


#1

Dear community,

We are currently trying to update the libcouchbase on a server :

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04.3 LTS
Release: 14.04
Codename: trusty

The lib version pre-installed is

ldconfig -v | grep couchbase
libcouchbase.so.2 -> libcouchbase.so.2.0.29
libcouchbase_libevent.so -> libcouchbase_libevent.so
libcouchbase_libev.so -> libcouchbase_libev.so
libcouchbase.so.2 -> libcouchbase.so.2.0.29
libcouchbase_libevent.so -> libcouchbase_libevent.so

When we follow the installation steps (Building on Unix-like systems) downoloading the version 2.5.3 (Releases) in the build directory $libpath/build/lib we do not obtain the new lib version but the libcouchbase.so.2.0.29 again after a ../cmake/configure and a make.

Also when we try to follow the instructions http://developer.couchbase.com/documentation/server/4.0/sdks/c-2.4/download-install.html the 2.5.3 is also never installed.

I hope you’ll be able to help us.

Thanks a lot


#2

Same issue. No matter how we install libcouchbase (either from the sources or the repository), it seems impossible to get the upgraded version of the lib on Ubuntu 14.

Jean


#3

Forgive me if I’m asking the obvious, but when building from source, did you do make install?

Additionally, while the product version is 2.5.3, the actual soname, meaning the API version, is actually 2.0.29 (as of the 2.5.3 release).

Therefore, everything seems to be in order.

Is there a specific reason you are trying to upgrade?


#4

Thank you @mnunberg for your reply,

Yes I did the make install. It seems that I was wrong thinking that the the .so version should reflect the package version.
How can I be sure that my binary files use the right version, I mean the 2.5.3?

To reply to your last question, I want to do the update because I have several client timeouts that occurs during pick loads and I think this is because the client library version is quiet old. Do you have any obvious actions that I should do to avoid them?


#5

The cbc version command should tell you the actual version of the library. You can also use lcb_version().

The “API” version is incremented with each new product release, so for example 2.5.2 would have appeared as 2.0.28, etc.

Timeouts might not be client related, but rather server-related. I would in general say that anything 2.4.x or newer is “current”. If you’re using a version older than 2.4, I’d recommend you upgrade.


#6

Thank you for your answers.
They was really helpful.