Web console - aws


#1

Hello,

I used this tutorial:
https://docs.couchbase.com/server/6.0/install/rhel-suse-install-intro.html#installing-using-code-class-cmd-yum-code

to install counchbase community on a aws ec2 instance…running:
sudo service couchbase-server start

I can see [OK] but when I try to accesso to my_ip:8091 I get ERR_CONNECTION_REFUSED…if I try to run:
couchbase soft nproc 4096 I get couchbase: command not found

on my iptables I allow everything and also on aws networking I allowed all connections…what I’m doing wrong?

many thanks
Francesco


#2

“couchbase soft nproc 4096” is not a command to be run from the shell. These are lines to be added to a conf file to set the process limits.

To set the process limits, create a .conf file in the /etc/security/limits.d directory (such as 91-couchbase.conf ), and add the following values:
couchbase soft nproc 4096
couchbase hard nproc 16384

Can you please do that and try to start the service again? Also please let us know the exact OS version that you are using and the build that you had used.


#3

HI,

shame on me…I didn’t read carefully the instructions, sorry…anyway I’ve added that lines but nothing changed:
this is my configurations:

NAME="Amazon Linux"
VERSION="2"
ID="amzn"
ID_LIKE="centos rhel fedora"
VERSION_ID="2"
PRETTY_NAME="Amazon Linux 2"

couchbase:

yum list installed | grep couchbase
couchbase-release.x86_64              1.0-5                          installed
couchbase-server-community.x86_64     6.0.0-1693                     @couchbase-server-community

I’ve installed also nginx to check if I was able to access the server and I’m able to get the nginx page (only over http).

These my rule on aws:

All traffic
All All 0.0.0.0/0
All traffic 
All All ::/0

here iptables:

sudo iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination
ACCEPT     all  --  anywhere             anywhere

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination

netstat -lntu:

tcp        0      0 0.0.0.0:111             0.0.0.0:*               LISTEN
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN
tcp        0      0 127.0.0.1:25            0.0.0.0:*               LISTEN
tcp6       0      0 :::111                  :::*                    LISTEN
tcp6       0      0 :::80                   :::*                    LISTEN
tcp6       0      0 :::22                   :::*                    LISTEN
udp        0      0 0.0.0.0:702             0.0.0.0:*
udp        0      0 127.0.0.1:323           0.0.0.0:*
udp        0      0 0.0.0.0:68              0.0.0.0:*
udp        0      0 0.0.0.0:111             0.0.0.0:*
udp6       0      0 :::702                  :::*
udp6       0      0 ::1:323                 :::*
udp6       0      0 xxx::xxx:xxx:xxxx::xxx  :::*
udp6       0      0 :::111                  :::*

I checked on the start.log I can see [FAILED]…so maybe something is not working right, but running
sudo service couchbase-server start
I get ok…

Edit: another info

systemctl status couchbase-server.service
● couchbase-server.service - LSB: couchbase server
   Loaded: loaded (/etc/rc.d/init.d/couchbase-server; bad; vendor preset: disabled)
   Active: active (exited) since Wed 2018-11-07 21:41:04 UTC; 3min 49s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 3762 ExecStop=/etc/rc.d/init.d/couchbase-server stop (code=exited, status=0/SUCCESS)
  Process: 3791 ExecStart=/etc/rc.d/init.d/couchbase-server start (code=exited, status=0/SUCCESS)

xxxx.eu-west-2.compute.internal systemd[1]: Starting LSB: couchbase server...
xxxx.eu-west-2.compute.internal couchbase-server[3791]: Starting couchbase-server-community
xxxx.eu-west-2.compute.internal runuser[3803]: pam_unix(runuser:session): session opened for user couchbase by (uid=0)
xxxx.eu-west-2.compute.internal couchbase-server[3791]: /opt/couchbase/lib/erlang/erts-5.10.4.0.0.1/bin/beam: error while loading shared libraries: libncurses.so.5: can... directory
xxxx.eu-west-2.compute.internal couchbase-server[3791]: [FAILED]
xxxx.eu-west-2.compute.internal systemd[1]: Started LSB: couchbase server.
Hint: Some lines were ellipsized, use -l to show in full.

Last info: I’m using an ec2 instance on free tier, so I think it is very small…maybe this is the problem? I;m not interested on performance, only play with an app created by me to learn…

I’m trying to reach:
http://ec2-xxx.compute.amazonaws.com:8091

ps. I don’t use linux/aws too much…so maybe there is something that I don’t see…

many thanks for your help
Francesco


#4

Thanks @francesco.venica for the info. Have you used the Couchbase AMI for AWS to get the couchbase server installed, or did you do a yum install ?

Amazon Linux is only supported when it is run using the official Couchbase Server AMI on AWS .
https://docs.couchbase.com/server/6.0/install/install-platforms.html


#5

I did a manual installation as the AMI has only paid tier…after reading better the errors I fix my problem (in thi moment) installing this:
sudo yum install libncurses*

now I can see the console