Wrong error handling BIG documents


#1

When sending big documents to Couchbase (>20Mb) it will report this error:

LCB_E2BIG: The object requested is too big to store in the server

If you keep pushing this further (for examle 40Mb) the error thrown is this one:

LCB_EINVAL_MCD: A badly formatted packet was sent to the server. Please report this in a bug

This is using the following encoding options:

$this->options = [
‘sertype’ => COUCHBASE_SERTYPE_PHP,
‘cmprtype’ => COUCHBASE_CMPRTYPE_NONE,
‘cmprthresh’ => 0,
‘cmprfactor’ => 0
];


#2

Thank, you @davidbcn, I will fix this by limiting it on the client side.