XDCR 3.0.2 going mental


#1

I am experimenting with 3.0.2 XDCR functionality

I keep getting couchbase trying to be “SMART” and getting confused by my network setup, and it takes my XDCR setting and throws it out the windows.

Here is the error message in the log:

Event:
Updated remote cluster VRMI1
hostname to “10.5.5.11:8091” because old one (“10.10.2.11:8091”) is not part of the cluster anymore

Module Code:
remote_clusters_info000

Now, on the far side of the VPN, the node name is the same as the local node name, and I am giving XDCR a WAN VPN address to reach the other cluster node.

I will run an experiment where I keep all node address different across clusters.

Any comments on a setting that can be thrown to keep couchbase from freaking out.

Thanks,

md


#2

This would be a great time to be able to change Server Node Names without having to drop the buckets and rebuild everything

I guess the design is such that all nodes are locked to each other, so maybe you really have to tear it all down just to build it up.


#3

This questions was answered in IRC forums. The solution is to NOT use IP addresses for server node names. Use English readable host names and then use your DNS services on each node to derive the proper address. Couchbase supposedly will not then get confused and go mental.

English names also help with IP Address changes.


#4

Hi MD1, Great that you found the answer through IRC forums. You can also refer to best-practices section in our documentation which covers this topic - http://docs.couchbase.com/couchbase-manual-2.5/cb-admin/#handling-changes-in-ip-addresses.