XDCR Sasl Auth error in one-way replication

replica

#1

Hi,

I’m using a simple one-way replication between clusters using Couchbase Community 5.0.1 edition.

Source Cluster has a bucket named primary with SASL password.

Destination Cluster has a bucket named primary without any sasl password (created through Web console UI).

Now when starting XDCR replication between these clusters for primary bucket fails with error, "MCResponse status=AUTH_ERROR, opcode=SASL_AUTH, opaque=0, msg: {“error”:{“ref”:“5556a521-57a8-46ce-9de0-92540afa04c5”}} ".

What am I doing wrong? Please help.

Thanks!


#2

@ingenthr Hi, any help here will be much appreciated! Thanks! Bucket password was added in 4.5 and after migrating to 5.0.1, user was automatically created with bucket name and password by CB. Does it have anything do with my XDCR issue I mentioned in description?


#3

Can someone help us here please? This has been a huge blocker for us now. Any help or guidance is really appreciated!


#4

It may be related. Are both clusters 5.0.1?

If so, I’d recommend creating a user with the required permissions in each cluster. Long story short, the 4.x automatically created users are intended for transparent migration, but you’re better off if you move to the newer way of doing things.

Also, see that error ref? That indicates there is likely something more in the logs (likely memcached.log) that will give you more information. The authenticating client isn’t told why the auth failed, but the server side will know if it’s a password that didn’t match, a permission that isn’t possible, etc.


#5

It worked Thanks! I had to create a user with same credentials. And memcached.log was the correct place. I always looked at xdcr_errors.log and did not see any logs.